jeudi 5 janvier 2012

Cours Tableur Excel 2007 : La fonction SI avec des Exercices Corrigés TP Excel Fonction SI avec correction

LA FONCTION SI

PRÉSENTATION


La fonction SI permet d’afficher des données ou de réaliser des calculs en fonction d’une condition déterminée.

= SI(condition;alors valeur si condition vraie;sinon valeur si condition fausse)

Pour définir la condition on utilise les opérateurs de comparaison suivants :

Opérateurs de comparaison
Signification
=
Est égal à
<>
Est différent de
<=
Est inférieur ou égal à
<
Est inférieur strictement à
>=
Est supérieur ou égal à
>
est supérieur strictement à

-----------------------------------------
La valeur peut être :
- l’affichage d’un texte entre des « »
- une référence de cellule
- une formule de calcul
-----------------------------------------
APPLICATION 1 Affichage d’un texte conditionnel (1 seule condition)

En fonction des résultats du bac, on souhaite afficher le texte suivant : « Admis » si la note est supérieur ou égal à 10 sinon on affiche la mention « Éliminé » :

Tableau à réaliser

Activité :


1) Précisez la formule, à implanter, dans la cellule C3, permettant d’obtenir automatiquement l’affichage de la mention à partir de la note du bac

Formule en C3 :

1) Réalisez le tableau avec Ms Office Excel 2007 – Nommez la feuille Application et sauvegardez le classeur sous le nom FONCSI

APPLICATION 2 Fonctions SI imbriquées (plusieurs conditions)

On désire que les mentions soient les suivantes :
Note < 10 : mention = Éliminé
Note comprise entre 10 et 12 inclus : Mention = Passable
Note comprise entre 12 et 14 inclus : Mention = Assez bien
Note > 14 : Mention = Bien

Tableau à réaliser :

Activité :
1) Combien de valeurs peut prendre la mention ? ____________________
2) Compte tenu de la conclusion formulée à l’application 1, combien y aura t’il de conditions ? _____________conditions soit _________ fonctions SI _____ imbriquées
3) Afin de déterminer la formule à implanter, il est possible de réaliser un « arbre de décision » mettant en évidence toutes les conditions possibles et les résultats associés. Complétez l’arbre de décision ci-dessous :

4) En vous aidant de l’arbre de décision ci-dessus, rédigez la formule à implanter dans la cellule C10

En C10 :

5) Réalisez le tableau (dans la même feuille de calcul que le tableau de l’application 1)

EXERCICE Compte banque schématique

Soit le compte schématique suivant :
Travail à faire :
1) Rédigez les formules du solde débiteur et du solde créditeur.
2) Réalisez le tableau dans une nouvelle feuille de calcul que vous nommerez EXERCICE
3) Sauvegardez le classeur

-------------------------------------------------------------------------------------------------------
Correction
-------------------------------------------------------------------------------------------------------

Corrigé Application N° 1

1) Réaliser le tableau sous MS-Excel 2007


2) Insérer la fonction SI




Donc la formule en C3 sera : =SI(B3<10;"Eliminé";"Admis")

Corrigé Application N° 2 : Fonctions SI imbriquées (plusieurs conditions)



1) Réaliser le tableau sous MS-Excel 2007


2) Insérer la Fonction "SI" dans la cellule "Mention"



3) Saisir la 1ère condition dans le champ "Test_Logique" puis dans le champ "valeur_si_vrai" tapez le texte à afficher "Eliminé" puis placer le curseur dans le champ "valeur_si_faux" puis cliquez sur "SI" en haut pour insérer une autre condition :


4) Saisir la nouvelle condition et refaire les mêmes étapes illustrées ci-dessus :


5) Saisir la dernière condition et valider par O.K



la formule finale sera :

=SI(B3<10;"Eliminé";SI(B3<12;"Passable";SI(B3<14;"Assez Bien";"Bien")))

Résultat final :

0 commentaires:

Enregistrer un commentaire

Share

Twitter Delicious Facebook Digg Stumbleupon Favorites

 

IP